A PHP Error was encountered

Severity: Warning

Message: Division by zero

Filename: public/Readmore.php

Line Number: 37

Backtrace:

File: /home/smktegal/public_html/application/controllers/public/Readmore.php
Line: 37
Function: _error_handler

File: /home/smktegal/public_html/index.php
Line: 315
Function: require_once

Mikrotik sebagai alternatif UPK 2018 | SMK NEGERI 2 KOTA TEGAL

SMK NEGERI 2 KOTA TEGAL

JL. WISANGGENI NO. 1

SMK BISA

Mikrotik sebagai alternatif UPK 2018

Jum'at, 29 September 2017 ~ Oleh Sekhidin ~ Dilihat 978 Kali

Persiapan UPK TKJ Tahun 2018 P3

Tanggal : 22-02-2017 11:58, dibaca 244 kali.


Anda bertindak sebagai Teknisi Jaringan. Tugas anda sebagai seorang teknisi Jaringan adalah merancang bangun dan mengkonfigurasi sebuah Wifi Router berfungsi sebagai Gateway Internet, Hotspot, DHCP Server, Bandwith Limiter dan Firewall, kemudian internet tersebut dishare ke client melalui jalur kabel (non hotspot) dan wireless (hotspot).

 

TOPOLOGI

Mengacu kepada topologi di atas yang saya ambil dari soal dan silahkan sesuaikan dengan kondisi kalian sendiri, saya sendiri akan sesuaikan menjadi
IP Kabel : 192.168.100.1/24
IP Nirkabel : 192.168.200.1/24
IP ISP : 172.16.0.45

Konfigurasi MikroTik Gateway

1. Berikan IP address pada setiap ether
/ip address
add address=172.16.0.45/24 interface=ether1 network=172.16.0.0
add address=192.168.100.1/24 interface=ether2 network=192.168.100.0
add address=192.168.200.1/24 interface=wlan1 network=192.168.200.0

 

2. Buat routing statis yang berfungsi untuk mengarahkan alamat yang tidak terdefinisikan di routing table ke gateway kita tentukan.
/ip route
add distance=1 dst-address=0.0.0.0/0 gateway=172.16.0.1


3. Agar jaringan lokal kita bisa terhubung dengan jaringan publik maka kita membutuhkan fitur NAT atau Network Address Translation. Untuk penjelasan lebih lanjut tentang NAT bisa melihat video saya disini

/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1

 

4. Agar router bisa melakukan resolve pada domain maka kita harus menambahkan konfigurasi DNS pada router. Silahkan teman-teman sesuaikan dengan DNS yang digunakan oleh ISP, namun jika tidak tahu kita pakai saja DNS dari Google
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4

 

5. Seharusnya kalian sudah bisa terhubung ke internet yang menandakan bahwa kita sudah berhasil membuat MikroTik Gateway, silahkan coba dengan ping via terminal di Router atau bisa juga melalui PC tapi jangan lupa sesuaikan IP Address PC nya ya. Contoh pada kasus ini saya menggunakan IP 192.168.100.2 pada PC saya yang terhubung via kabel.  ^_^

Blok YouTube

Ada berbagai macam kombinasi untuk memblokir traffic yang melaju ke YouTube. Namun karena pada kondisi ujian saya tidak yakin teman-teman menggunakan versi RouterOS yang sama maka saya menggunakan cara yang bisa digunakan di sebagian besar RouterOS. Caranya adalah dengan menggunakan keyword pada setiap paket yang melalui router.
/ip firewall filter
add action=drop chain=forward content=youtube.com in-interface=ether2 out-interface=ether1

Kalau sudah silahkan buka www.youtube.com melalui browser dan seharusnya tidak bisa dibuka

Wireless

Karena di awal kita sudah melakukan konfigurasi IP address pada wlan1 jadi kita langsung saja mengganti SSID pada wlan1. Untuk cara ceknya silahkan lihat saja di client apakah muncul wireless dengan SSID kamal@hotspot
/interface wireless
set [ find default-name=wlan1 ] disabled=no l2mtu=1600 mode=ap-bridge ssid=kamal@hotspot

 

Hotspot

1.Untuk Hotspot agar lebih mudah saya gunakan GUI (winbox). Silahkan ke IP > Hotspot
 
2. Pada bagian ini karena kita sudah buat NAT di awal tadi maka uncheck bagian Masquerade Network
3. Karena pada bagian Hotspot kita sekalian juga set DHCP Server maka silahkan memasukkan Address Pool sesuai dengan soal
4. Karena tidak memiliki sertifikat SSL maka pada bagian ini langsung Next saja
5. Karena tidak memiliki SMTP server jadi biarkan saja dan langsung Next
6. Karena di awal tadi kita sudah gunakan melakukan konfigurasi untuk DNS maka di sini DNS yang kita masukkan langsung ada. Kita bisa tambahkan atau sunting juga tapi mending tidak usah dan biarkan menggunakan yang dari sistem
7. DNS name of local hotspot server adalah domain yang kita gunakan jika ingin membuka portal hotspot, isi sesuai dengan permintaan soal yaitu sekolah.sch.id
8. Terakhir masukkan user untuk login hotspot dan isi juga passwordnya.
9. Sekarang hotspot sudah siap, teman-teman bisa coba dengan mengkoneksikan ke wireless lalu buka browser dan seharusnya ketika ingin mengakses internet harus login terlebih dahulu.

Bypass bsnp-indonesia.org

Ketika kita mengaktifkan fitur hotspot maka seluruh situs akan ditutup (harus login dulu). Bypass itu dimaksudkan agar user yang belum/tidak login bisa mengakes situs yang telah ditentukan. Untuk caranya silahkan lihat di bawah ini
Jika ingin via CLI bisa lihat cara berikut
/ip hotspot walled-garden
add dst-host=bsnp-indonesia.org
Sekarang silahkan akses bsnp-indonesia.org dengan catatan sudah tidak terkoneksi ke internet. Kalian bisa logout terlebih dahulu, jika tidak mau logout silahkan untuk uncheck cache pada bagian di bawah ini dan coba lagi akses bsnp-indonesia.org

Hotspot User

User pada MikroTik berbasis pada User Profile, maka dari itu kita harus buat 2 User Profile terlebih dahulu yaitu Guru dengan bandwidth unlimited dan siste dengan bandwidth upload/download = 256kbps
/ip hotspot user profile
add name=guru shared-users=unlimited transparent-proxy=yes
add name=siswa rate-limit=256/256 shared-users=unlimited transparent-proxy=yes


Setelah itu kita buat user username guru & siswa yang dikaitkan kepada profile masing-masing.

/ip hotspot user
add name=guru password=guru profile=guru
add name=siswa password=siswa profile=siswa


Sekarang silahkan untuk menguji masing-masing user dengan kecepatannya. Jika tidak sesuai pastikan pada bagian user profile sesuai dengan aturan yang diberikan pada soal.

Ubah Tampilan Portal Login

Untuk mengubah tampilan sebenarnya kita tinggal memasukkan dokumen tampilan hotspot ke Router. Dan cara yang paling mudah adalah dengan melakukan click & drag via winbox. Tapi sebelumnya siapkan terlebih dahulu file dan lakukan drag ke FILES. Sebagai contoh di bawah ini saya drag langsung folder login pada direktori atas.
Jika sudah maka kita akan membuat jika ada yang mengakses hotspot portal maka akan diarakan ke tampilan yang berada di direktori login. Silahkan pergi ke IP > Hotspot dan ikut petunjuk di bawah ini dan jika sudah silahkan buka kembali portal login hotspot di browser.
Segitu dulu saja untuk dokumentasi pembahasan UKK TKJ tahun 2016/2017 paket 3. Sebenarnya jika saya lihat sih hampir tidak ada bedanya dengan tahun lalu. Kalau ada yang kurang atau yang mau ditanyakan silahkan berikan komentar. Kalau bingung yang versi artikel ini silahkan bisa lihat versi video di bawah ini

KOMENTARI TULISAN INI

  1. TULISAN TERKAIT
...

SRI INDRAWATI, M.Pd.

Assalamu'alaikum Wr. Wb.  Puja dan puji syukur kita panjatkan kehadapan Tuhan Yang Maha Esa. karena berkat rahmat-Nyalah Website SMK 2 Tegal telah…

Selengkapnya

JAJAK PENDAPAT

Bagaimana pendapat anda mengenai web sekolah kami ?

LIHAT HASIL